Module: Grape

Defined in:
lib/grape/middleware/versioner.rb,
lib/grape.rb,
lib/grape/api.rb,
lib/grape/path.rb,
lib/grape/route.rb,
lib/grape/cookies.rb,
lib/grape/version.rb,
lib/grape/endpoint.rb,
lib/grape/namespace.rb,
lib/grape/parser/xml.rb,
lib/grape/validations.rb,
lib/grape/parser/json.rb,
lib/grape/parser/base.rb,
lib/grape/http/request.rb,
lib/grape/formatter/xml.rb,
lib/grape/formatter/txt.rb,
lib/grape/formatter/base.rb,
lib/grape/formatter/json.rb,
lib/grape/util/hash_stack.rb,
lib/grape/middleware/base.rb,
lib/grape/exceptions/base.rb,
lib/grape/middleware/error.rb,
lib/grape/middleware/filter.rb,
lib/grape/util/content_types.rb,
lib/grape/middleware/globals.rb,
lib/grape/validations/regexp.rb,
lib/grape/validations/coerce.rb,
lib/grape/validations/values.rb,
lib/grape/error_formatter/txt.rb,
lib/grape/validations/default.rb,
lib/grape/error_formatter/xml.rb,
lib/grape/validations/presence.rb,
lib/grape/error_formatter/json.rb,
lib/grape/error_formatter/base.rb,
lib/grape/middleware/formatter.rb,
lib/grape/middleware/auth/base.rb,
lib/grape/middleware/auth/basic.rb,
lib/grape/exceptions/validation.rb,
lib/grape/middleware/auth/digest.rb,
lib/grape/exceptions/missing_option.rb,
lib/grape/middleware/versioner/path.rb,
lib/grape/middleware/versioner/param.rb,
lib/grape/exceptions/unknown_options.rb,
lib/grape/formatter/serializable_hash.rb,
lib/grape/middleware/versioner/header.rb,
lib/grape/exceptions/validation_errors.rb,
lib/grape/exceptions/unknown_validator.rb,
lib/grape/exceptions/invalid_formatter.rb,
lib/grape/exceptions/missing_mime_type.rb,
lib/grape/exceptions/missing_vendor_option.rb,
lib/grape/exceptions/invalid_versioner_option.rb,
lib/grape/exceptions/incompatible_option_values.rb,
lib/grape/middleware/versioner/accept_version_header.rb,
lib/grape/exceptions/invalid_with_option_for_represent.rb

Overview

Versioners set env['api.version'] when a version is defined on an API and on the requests. The current methods for determining version are:

:header - version from HTTP Accept header. :path - version from uri. e.g. /v1/resource :param - version from uri query string, e.g. /v1/resource?apiver=v1

See individual classes for details.

Defined Under Namespace

Modules: ContentTypes, ErrorFormatter, Exceptions, Formatter, Middleware, Parser, Util, Validations Classes: API, Cookies, Endpoint, Namespace, Path, Request, Route

Constant Summary

VERSION =
'0.7.0'