Module: Merb::Generators

Extended by:
Templater::Manifold
Defined in:
merb-gen/lib/merb-gen/version.rb,
merb-gen/lib/merb-gen/generator.rb,
merb-gen/lib/merb-gen/app_generator.rb,
merb-gen/lib/merb-gen/named_generator.rb,
merb-gen/lib/merb-gen/namespaced_generator.rb

Defined Under Namespace

Classes: AppGenerator, Generator, NamedGenerator, NamespacedGenerator

Constant Summary

VERSION =
'1.2.0'.freeze
DM_VERSION_REQUIREMENT =

Duplicated here (originally in merb_datamapper) This is currently the easiest way to get at the datamapper version requirements, and still seems better than specifying the datamapper version in merb-core itself.

'~> 1.0'.freeze
DO_VERSION_REQUIREMENT =

Necessary to supply builtin support for do_sqlite3

'~> 1.0'.freeze
AUTH_VERSION_REQUIREMENT =

merb-auth has separate versioning scheme as well

'~> 1.0'.freeze