Development

Full Changelog

Enhancements:

Bug Fixes:

3.0.2 / 2014-07-21

Full Changelog

Bug Fixes:

3.0.1 / 2014-06-02

Full Changelog

Bug Fixes:

3.0.0 / 2014-06-01

Full Changelog

Enhancements:

Bug Fixes:

3.0.0.rc1 / 2014-05-18

Full Changelog

Breaking Changes for 3.0.0:

Enhancements:

Bug Fixes:

3.0.0.beta2 / 2014-02-17

Full Changelog

Breaking Changes for 3.0.0:

Enhancements:

Bug Fixes:

3.0.0.beta1 / 2013-11-07

Full Changelog

Breaking Changes for 3.0.0:

2.99.0 / 2014-06-01

Full Changelog

No changes. Just taking it out of pre-release.

2.99.0.rc1 / 2014-05-18

Full Changelog

Deprecations

2.99.0.beta2 / 2014-02-17

Full Changelog

Deprecations:

Bug Fixes:

2.99.0.beta1 / 2013-11-07

Full Changelog

Deprecations:

Enhancements:

Bug Fixes:

2.14.1 / 2013-12-29

full changelog

Bug Fixes:

2.14.0 / 2013-07-06

Full Changelog

Bug fixes

2.14.0.rc1 / 2013-05-27

Full Changelog

Enhancements

Bug fixes

2.13.2 / 2013-05-18

Full Changelog

Bug fixes

Enhancements

2.13.1 / 2013-04-27

Full Changelog

Bug fixes

2.13.0 / 2013-02-23

Full Changelog

Enhancements

2.12.2 / 2013-01-12

Full Changelog

Bug fixes

2.12.1 / 2013-01-07

Full Changelog

Bug fixes

2.12.0 / 2012-11-12

Full Changelog

Enhancements

Bug fixes

2.11.4 / 2012-10-14

Full Changelog

Capybara-2.0 integration support:

See https://github.com/jnicklas/capybara/pull/809 and http://rubydoc.info/gems/rspec-rails/file/Capybara.md for background.

2.11.1, .2, .3 were yanked due to errant documentation.

2.11.0 / 2012-07-07

Full Changelog

Enhancements

Bug fixes

2.10.1 / 2012-05-03

Full Changelog

Bug fixes

2.10.0 / 2012-05-03

Full Changelog

Bug fixes

2.9.0 / 2012-03-17

Full Changelog

Enhancements

Bug fixes

2.8.1 / 2012-01-04

Full Changelog

NOTE: there was a change in rails-3.2.0.rc2 which broke compatibility with stub_model in rspec-rails. This release fixes that issue, but it means that you'll have to upgrade to rspec-rails-2.8.1 when you upgrade to rails >= 3.2.0.rc2.

2.8.0 / 2012-01-04

Full Changelog

2.8.0.rc2 / 2011-12-19

Full Changelog

2.8.0.rc1 / 2011-11-06

Full Changelog

2.7.0 / 2011-10-16

Full Changelog

2.6.1 / 2011-05-25

Full Changelog

This release is compatible with rails-3.1.0.rc1, but not rails-3.1.0.beta1

2.6.0 / 2011-05-12

Full Changelog

2.5.0 / 2011-02-05

Full Changelog

2.4.1 / 2011-01-03

Full Changelog

2.4.0 / 2011-01-02

Full Changelog

2.3.1 / 2010-12-16

Full Changelog

2.3.0 / 2010-12-12

Full Changelog

2.2.1 / 2010-12-01

Full Changelog

2.2.0 / 2010-11-28

Full Changelog

2.1.0 / 2010-11-07

Full Changelog

2.0.1 / 2010-10-15

Full Changelog

2.0.0 / 2010-10-10

Full Changelog