Class: Spork::AppFramework::Rails

Inherits:
Spork::AppFramework show all
Defined in:
lib/spork/app_framework/rails.rb

Constant Summary

Constant Summary

Constants inherited from Spork::AppFramework

SUPPORTED_FRAMEWORKS

Instance Method Summary (collapse)

Methods inherited from Spork::AppFramework

[], #bootstrap_required?, detect_framework, detect_framework_name, setup_autoload, short_name, #short_name

Instance Method Details

- (Object) application_file



21
22
23
# File 'lib/spork/app_framework/rails.rb', line 21

def application_file
  @application_file ||= File.join(File.dirname(environment_file), 'application')
end

- (Object) boot_file



17
18
19
# File 'lib/spork/app_framework/rails.rb', line 17

def boot_file
  @boot_file ||= File.join(File.dirname(environment_file), 'boot')
end

- (Object) deprecated_version



33
34
35
36
37
38
39
40
41
# File 'lib/spork/app_framework/rails.rb', line 33

def deprecated_version
  @version ||= (
    if /^[^#]*RAILS_GEM_VERSION\s*=\s*["']([!~<>=]*\s*[\d.]+)["']/.match(environment_contents)
      $1
    else
      nil
    end
  )
end

- (Object) entry_point Also known as: environment_file



11
12
13
# File 'lib/spork/app_framework/rails.rb', line 11

def entry_point
  @entry_point ||= File.expand_path("config/environment.rb", Dir.pwd)
end

- (Object) environment_contents



25
26
27
# File 'lib/spork/app_framework/rails.rb', line 25

def environment_contents
  @environment_contents ||= File.read(environment_file)
end

- (Object) preload(&block)



3
4
5
6
7
8
9
# File 'lib/spork/app_framework/rails.rb', line 3

def preload(&block)
  STDERR.puts "Preloading Rails environment"
  STDERR.flush
  ENV["RAILS_ENV"] ||= 'test'
  preload_rails
  yield
end

- (Object) preload_rails



43
44
45
46
47
48
49
50
51
52
53
54
55
56
57
58
59
60
61
62
63
64
65
66
67
68
69
70
71
72
73
74
75
76
77
78
79
80
# File 'lib/spork/app_framework/rails.rb', line 43

def preload_rails
  if deprecated_version && (not /^3/.match(deprecated_version))
    puts "This version of spork only supports Rails 3.0. To use spork with rails 2.3.x, downgrade to spork 0.8.x."
    exit 1
  end
  require application_file
  ::Rails.application
  ::Rails::Engine.class_eval do
    def eager_load!
      # turn off eager_loading, all together
    end
  end
  # Spork.trap_method(::AbstractController::Helpers::ClassMethods, :helper)
  Spork.trap_method(::ActiveModel::Observing::ClassMethods, :instantiate_observers)
  Spork.each_run { ActiveRecord::Base.establish_connection rescue nil } if Object.const_defined?(:ActiveRecord)


  AbstractController::Helpers::ClassMethods.module_eval do
    def helper(*args, &block)
      ([args].flatten - [:all]).each do |arg|
        next unless arg.is_a?(String)
        filename = arg + "_helper"
        unless ::ActiveSupport::Dependencies.search_for_file(filename)
          # this error message must raise in the format such that LoadError#path returns the filename
          raise LoadError.new("Missing helper file helpers/%s.rb" % filename)
        end
      end

      Spork.each_run(false) do
        modules_for_helpers(args).each do |mod|
          add_template_helper(mod)
        end

        _helpers.module_eval(&block) if block_given?
      end
    end
  end
end

- (Object) vendor



29
30
31
# File 'lib/spork/app_framework/rails.rb', line 29

def vendor
  @vendor ||= File.expand_path("vendor/rails", Dir.pwd)
end