Circular Queue

Gem Version Build Status

Data structure that uses a single, fixed-size buffer as if it were connected end-to-end.

Support

circular_queue officially supports the currently supported Ruby versions, which tends to mean the last three major release. As of now that's Ruby 2.6, 2.5, and 2.4. Older Rubies, back to Ruby 1.9, might work, but are not officially supported.

Documentation

Documentation, including example use, is covered in the API Docs.

Changelog

License