Class: Impressionist::RailsToggle

Inherits:
Object
  • Object
show all
Defined in:
lib/impressionist/rails_toggle.rb

Overview

Responsibility Toggles between rails > 3.1 < 4 In order to make attr_accessible available in a rails app < 4

Instance Method Summary collapse

Instance Method Details

#should_include?Boolean

decides where or not to include attr_accessible

Returns:

  • (Boolean)

8
9
10
# File 'lib/impressionist/rails_toggle.rb', line 8

def should_include?
  supported_by_rails? && (not using_strong_parameters?)
end