Module: Hyperkit

Extended by:
Configurable
Defined in:
lib/hyperkit.rb,
lib/hyperkit/error.rb,
lib/hyperkit/client.rb,
lib/hyperkit/utility.rb,
lib/hyperkit/default.rb,
lib/hyperkit/version.rb,
lib/hyperkit/connection.rb,
lib/hyperkit/configurable.rb,
lib/hyperkit/client/images.rb,
lib/hyperkit/client/profiles.rb,
lib/hyperkit/client/networks.rb,
lib/hyperkit/client/operations.rb,
lib/hyperkit/client/containers.rb,
lib/hyperkit/client/certificates.rb,
lib/hyperkit/response/raise_error.rb,
lib/hyperkit/middleware/follow_redirects.rb

Overview

Ruby toolkit for the LXD API. LXD - the next-generation container hypervisor for Linux

Defined Under Namespace

Modules: Configurable, Connection, Default, Middleware, Response, Utility Classes: AliasAttributesRequired, BadGateway, BadRequest, Client, ClientError, Conflict, Error, Forbidden, ImageIdentifierRequired, InternalServerError, InvalidImageAttributes, InvalidProtocol, MethodNotAllowed, MissingProfiles, NotAcceptable, NotFound, NotImplemented, ServerError, ServiceUnavailable, Unauthorized, UnprocessableEntity, UnsupportedMediaType

Constant Summary collapse

VERSION =
"1.0.1"

Instance Attribute Summary

Attributes included from Configurable

#api_endpoint, #auto_sync, #client_cert, #client_key, #default_media_type, #middleware, #proxy, #user_agent, #verify_ssl

Class Method Summary collapse

Methods included from Configurable

configure, keys, reset!, same_options?

Class Method Details

.clientHyperkit::Client

API client based on configured options Configurable


36
37
38
39
# File 'lib/hyperkit.rb', line 36

def client
  return @client if defined?(@client) && @client.same_options?(options)
  @client = Hyperkit::Client.new(options)
end