Class: Bundler::CLI::Update

Inherits:
Object
  • Object
show all
Defined in:
lib/bundler/cli/update.rb

Instance Attribute Summary collapse

Instance Method Summary collapse

Constructor Details

#initialize(options, gems) ⇒ Update

Returns a new instance of Update.


6
7
8
9
# File 'lib/bundler/cli/update.rb', line 6

def initialize(options, gems)
  @options = options
  @gems = gems
end

Instance Attribute Details

#gemsObject (readonly)

Returns the value of attribute gems


5
6
7
# File 'lib/bundler/cli/update.rb', line 5

def gems
  @gems
end

#optionsObject (readonly)

Returns the value of attribute options


5
6
7
# File 'lib/bundler/cli/update.rb', line 5

def options
  @options
end

Instance Method Details

#runObject


11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
57
58
59
60
61
62
63
64
65
66
67
68
69
70
71
72
73
74
75
76
77
78
79
80
81
82
83
84
85
86
87
88
89
90
91
92
93
94
95
96
97
98
99
100
101
102
103
104
105
106
107
108
109
# File 'lib/bundler/cli/update.rb', line 11

def run
  Bundler.ui.level = "error" if options[:quiet]

  Plugin.gemfile_install(Bundler.default_gemfile) if Bundler.feature_flag.plugins?

  sources = Array(options[:source])
  groups  = Array(options[:group]).map(&:to_sym)

  full_update = gems.empty? && sources.empty? && groups.empty? && !options[:ruby] && !options[:bundler]

  if full_update && !options[:all]
    if Bundler.feature_flag.update_requires_all_flag?
      raise InvalidOption, "To update everything, pass the `--all` flag."
    end
    SharedHelpers.major_deprecation 3, "Pass --all to `bundle update` to update everything"
  elsif !full_update && options[:all]
    raise InvalidOption, "Cannot specify --all along with specific options."
  end

  if full_update
    # We're doing a full update
    Bundler.definition(true)
  else
    unless Bundler.default_lockfile.exist?
      raise GemfileLockNotFound, "This Bundle hasn't been installed yet. " \
        "Run `bundle install` to update and install the bundled gems."
    end
    Bundler::CLI::Common.ensure_all_gems_in_lockfile!(gems)

    if groups.any?
      deps = Bundler.definition.dependencies.select {|d| (d.groups & groups).any? }
      gems.concat(deps.map(&:name))
    end

    Bundler.definition(:gems => gems, :sources => sources, :ruby => options[:ruby],
                       :lock_shared_dependencies => options[:conservative],
                       :bundler => options[:bundler])
  end

  Bundler::CLI::Common.configure_gem_version_promoter(Bundler.definition, options)

  Bundler::Fetcher.disable_endpoint = options["full-index"]

  opts = options.dup
  opts["update"] = true
  opts["local"] = options[:local]

  Bundler.settings.set_command_option_if_given :jobs, opts["jobs"]

  Bundler.definition.validate_runtime!

  if locked_gems = Bundler.definition.locked_gems
    previous_locked_info = locked_gems.specs.reduce({}) do |h, s|
      h[s.name] = { :spec => s, :version => s.version, :source => s.source.to_s }
      h
    end
  end

  installer = Installer.install Bundler.root, Bundler.definition, opts
  Bundler.load.cache if Bundler.app_cache.exist?

  if CLI::Common.clean_after_install?
    require_relative "clean"
    Bundler::CLI::Clean.new(options).run
  end

  if locked_gems
    gems.each do |name|
      locked_info = previous_locked_info[name]
      next unless locked_info

      locked_spec = locked_info[:spec]
      new_spec = Bundler.definition.specs[name].first
      unless new_spec
        if Bundler.rubygems.platforms.none? {|p| locked_spec.match_platform(p) }
          Bundler.ui.warn "Bundler attempted to update #{name} but it was not considered because it is for a different platform from the current one"
        end

        next
      end

      locked_source = locked_info[:source]
      new_source = new_spec.source.to_s
      next if locked_source != new_source

      new_version = new_spec.version
      locked_version = locked_info[:version]
      if new_version < locked_version
        Bundler.ui.warn "Note: #{name} version regressed from #{locked_version} to #{new_version}"
      elsif new_version == locked_version
        Bundler.ui.warn "Bundler attempted to update #{name} but its version stayed the same"
      end
    end
  end

  Bundler.ui.confirm "Bundle updated!"
  Bundler::CLI::Common.output_without_groups_message(:update)
  Bundler::CLI::Common.output_post_install_messages installer.post_install_messages
end