Class: Bundler::CLI::Viz

Inherits:
Object
  • Object
show all
Defined in:
lib/bundler/cli/viz.rb

Instance Attribute Summary collapse

Instance Method Summary collapse

Constructor Details

#initialize(options) ⇒ Viz

Returns a new instance of Viz.


6
7
8
# File 'lib/bundler/cli/viz.rb', line 6

def initialize(options)
  @options = options
end

Instance Attribute Details

#gem_nameObject (readonly)

Returns the value of attribute gem_name


5
6
7
# File 'lib/bundler/cli/viz.rb', line 5

def gem_name
  @gem_name
end

#optionsObject (readonly)

Returns the value of attribute options


5
6
7
# File 'lib/bundler/cli/viz.rb', line 5

def options
  @options
end

Instance Method Details

#runObject


10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
# File 'lib/bundler/cli/viz.rb', line 10

def run
  # make sure we get the right `graphviz`. There is also a `graphviz`
  # gem we're not built to support
  gem "ruby-graphviz"
  require "graphviz"

  options[:without] = options[:without].join(":").tr(" ", ":").split(":")
  output_file = File.expand_path(options[:file])

  graph = Graph.new(Bundler.load, output_file, options[:version], options[:requirements], options[:format], options[:without])
  graph.viz
rescue LoadError => e
  Bundler.ui.error e.inspect
  Bundler.ui.warn "Make sure you have the graphviz ruby gem. You can install it with:"
  Bundler.ui.warn "`gem install ruby-graphviz`"
rescue StandardError => e
  raise unless e.message =~ /GraphViz not installed or dot not in PATH/
  Bundler.ui.error e.message
  Bundler.ui.warn "Please install GraphViz. On a Mac with Homebrew, you can run `brew install graphviz`."
end